We are pleased to advise that all deliveries are now running to schedule, following the inclement weather. We apologise for any inconvenience and thank you for your patience.
Posted Jan 12, 2026 - 16:23 UTC
Identified
Our courier company have reached out to notify Pangea that delays of up to 72 hours are affecting deliveries in certain parts of the UK:
- Northern Scotland - North Wales - Mid Wales - North Midlands - East Midlands
Any parcels due for delivery today are likely to be affected. We apologise for these delays. You can get the latest information on your delivery from Pangea by visiting the following URL and entering the reference number provided on your dispatch e-mail: https://missionexp.couriernavigator-secure.com/tracking.html
Please do not hesitate to contact our support team if you require further assistance.
Posted Jan 05, 2026 - 13:05 UTC
This incident affected: Pangea Operations (Fulfilment, Shipping & Delivery).