EE Outage

Incident Report for Pangea Connected

Resolved

It has been confirmed that the work completed at 13:31 to move services to a new link has resolved the issue.

During subsequent monitoring we observed customers attaching to the network as expected with levels returning to BAU.

There will be no further communications for this incident.

If you have any further questions or need us to attempt to steer a SIM please contact support:

0800 470 4070

Support@pangea-group.net
Posted Nov 18, 2025 - 14:55 UTC

Identified

EE have identified the issue and are working on a fix. The issue is isolated to roaming SIMs for inbound and outbound connections. Singlenetwork EE UK SIMs should not be affected.

We will provide the next update as soon as we receive it from EE.

If you have any further questions or need us to attempt to steer a SIM please contact support:
0800 470 4070
Support@pangea-group.net

Thanks

Pangea Support Team
Posted Nov 18, 2025 - 13:25 UTC

Investigating

We have been advised by EE there is an ongoing issue on their network - this is affecting roaming multinetwork SIMs as well - we will update you when we have more information.

In the meantime you can try and steer your device to another network, or you can call our support team for a SIM refresh to hopefully get the SIM connected to a new network if it is a multinetwork SIM.
Posted Nov 18, 2025 - 12:24 UTC
This incident affected: Multi-Network SIM Operators (8931 ICCID Prefix (Non-L2TP Connections), 8931 ICCID Prefix (L2TP Connections), 89353 ICCID Prefix, 8946 ICCID Prefix, 8934 ICCID Prefix, 894453 ICCID Prefix, 8935711 ICCID Prefix).